DetectX update error on El Capitan

We just released version 2.04 of DetectX, but if you’re finding that you can’t update, here’s the reason (and the fix!).

Thanks to Apple’s new AppTransport security layer and Amazon S3 not supporting perfect forward secrecy protocol, users of DetectX on any version prior to 2.04 who are running El Capitan (OSX 10.11) will find that DetectX can’t be updated from within the app even though we use a secure https connection.

The simple, if inconvenient fix, is to download DetectX directly from sqwarq. We’ve fixed the bug so that once you’re on v2.04, the in-app update mechanism will function properly again (even on El Capitan !).

About philastokes

Freelance Writer, Developer and Technical Communicator. Explaining the unexplainable with images, video and text. Scripting anything imaginable in Applescript, Bash, C, Objective C, Cocoa, Python and Xcode.

Posted on October 21, 2015, in 10.11 and tagged , . Bookmark the permalink. Comments Off on DetectX update error on El Capitan.

Comments are closed.

%d bloggers like this: